Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nats
  4. ›
  5. CVE-2020-26149

CVE-2020-26149: Insufficiently Protected Credentials

September 30, 2020 (updated October 9, 2020)

NATS nats.js, nats.ws, and nats.deno allow credential disclosure from a client to a server.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-26149

Code Behaviors & Features

Detect and mitigate CVE-2020-26149 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.0-209

Fixed versions

  • 2.0.0-209

Solution

Upgrade to 2.0.0-209 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

npm/nats/CVE-2020-26149.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:37 +0000.