Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nats.ws
  4. ›
  5. CVE-2020-26149

CVE-2020-26149: Insufficiently Protected Credentials

October 8, 2020 (updated October 4, 2021)

NATS nats.js, nats.ws, and nats.deno allow credential disclosure from a client to a server.

References

  • www.openwall.com/lists/oss-security/2020/09/30/3
  • github.com/advisories/GHSA-82rf-q3pr-4f6p
  • github.com/nats-io/nats.deno/compare/v1.0.0-8...v1.0.0-9
  • github.com/nats-io/nats.ws/commit/0a37ac2a411ff63f0707cda69a268c5fc4079eb7
  • nvd.nist.gov/vuln/detail/CVE-2020-26149

Code Behaviors & Features

Detect and mitigate CVE-2020-26149 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.0-85 up to 1.0.0-110

Fixed versions

  • 1.0.0-111

Solution

Upgrade to version 1.0.0-111 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

npm/nats.ws/CVE-2020-26149.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.