Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. multer
  4. ›
  5. CVE-2026-3520

CVE-2026-3520: Multer Vulnerable to Denial of Service via Uncontrolled Recursion

March 5, 2026

A vulnerability in Multer versions < 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow.

References

  • cna.openjsf.org/security-advisories.html
  • github.com/advisories/GHSA-5528-5vmv-3xc2
  • github.com/expressjs/multer
  • github.com/expressjs/multer/commit/7e66481f8b2e6c54b982b34c152479e096ce2752
  • github.com/expressjs/multer/security/advisories/GHSA-5528-5vmv-3xc2
  • nvd.nist.gov/vuln/detail/CVE-2026-3520
  • www.cve.org/CVERecord?id=CVE-2026-3520

Code Behaviors & Features

Detect and mitigate CVE-2026-3520 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.1

Fixed versions

  • 2.1.1

Solution

Upgrade to version 2.1.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-674: Uncontrolled Recursion

Source file

npm/multer/CVE-2026-3520.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.