Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. multer
  4. ›
  5. CVE-2026-3304

CVE-2026-3304: Multer vulnerable to Denial of Service via incomplete cleanup

March 1, 2026

A vulnerability in Multer versions < 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing resource exhaustion.

References

  • cna.openjsf.org/security-advisories.html
  • github.com/advisories/GHSA-xf7r-hgr6-v32p
  • github.com/expressjs/multer
  • github.com/expressjs/multer/commit/739919097dde3921ec31b930e4b9025036fa74ee
  • github.com/expressjs/multer/security/advisories/GHSA-xf7r-hgr6-v32p
  • nvd.nist.gov/vuln/detail/CVE-2026-3304
  • www.cve.org/CVERecord?id=CVE-2026-3304

Code Behaviors & Features

Detect and mitigate CVE-2026-3304 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.0

Fixed versions

  • 2.1.0

Solution

Upgrade to version 2.1.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-459: Incomplete Cleanup

Source file

npm/multer/CVE-2026-3304.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:07 +0000.