Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. multer
  4. ›
  5. CVE-2025-48997

CVE-2025-48997: Multer vulnerable to Denial of Service via unhandled exception

June 5, 2025 (updated November 10, 2025)

A vulnerability in Multer versions >=1.4.4-lts.1, <2.0.1 allows an attacker to trigger a Denial of Service (DoS) by sending an upload file request with an empty string field name. This request causes an unhandled exception, leading to a crash of the process.

References

  • github.com/advisories/GHSA-g5hg-p3ph-g8qg
  • github.com/expressjs/multer
  • github.com/expressjs/multer/commit/35a3272b611945155e046dd5cef11088587635e9
  • github.com/expressjs/multer/issues/1233
  • github.com/expressjs/multer/pull/1256
  • github.com/expressjs/multer/security/advisories/GHSA-g5hg-p3ph-g8qg
  • nvd.nist.gov/vuln/detail/CVE-2025-48997

Code Behaviors & Features

Detect and mitigate CVE-2025-48997 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.4.4-lts.1 before 2.0.1

Fixed versions

  • 2.0.1

Solution

Upgrade to version 2.0.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-248: Uncaught Exception

Source file

npm/multer/CVE-2025-48997.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:49 +0000.