Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. mongosh
  4. ›
  5. CVE-2025-1756

CVE-2025-1756: mongosh vulnerable to local privilege escalation

February 27, 2025

mongosh may be susceptible to local privilege escalation under certain conditions potentially enabling unauthorized actions on a user’s system with elevated privilege, when a crafted file is stored in C:\node_modules. This issue affects mongosh prior to 2.3.0.

References

  • access.redhat.com/errata/RHSA-2025:1756
  • github.com/advisories/GHSA-f5w3-73h4-jpcm
  • github.com/mongodb-js/mongosh
  • jira.mongodb.org/browse/MONGOSH-2028
  • nvd.nist.gov/vuln/detail/CVE-2025-1756

Code Behaviors & Features

Detect and mitigate CVE-2025-1756 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.0

Fixed versions

  • 2.3.0

Solution

Upgrade to version 2.3.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-426: Untrusted Search Path

Source file

npm/mongosh/CVE-2025-1756.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.