Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. method-override
  4. ›
  5. CVE-2017-16136

CVE-2017-16136: Uncontrolled Resource Consumption

June 7, 2018 (updated October 9, 2019)

method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client does not support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.

References

  • nvd.nist.gov/vuln/detail/CVE-2017-16136

Code Behaviors & Features

Detect and mitigate CVE-2017-16136 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.3.10

Fixed versions

  • 2.3.10

Solution

Upgrade to version 2.3.10 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

npm/method-override/CVE-2017-16136.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:17 +0000.