Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. linux-cmdline
  4. ›
  5. CVE-2020-7704

CVE-2020-7704: Improper Input Validation

August 17, 2020 (updated July 21, 2021)

The package linux-cmdline is vulnerable to Prototype Pollution via the constructor.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-7704

Code Behaviors & Features

Detect and mitigate CVE-2020-7704 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.0.1

Fixed versions

  • 1.0.1

Solution

Upgrade to version 1.0.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/linux-cmdline/CVE-2020-7704.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:08 +0000.