Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. less-openui5
  4. ›
  5. CVE-2021-21316

CVE-2021-21316: Injection Vulnerability

February 16, 2021 (updated February 26, 2021)

In less-openui5, when processing theming resources (i.e. *.less files) with less-openui5 that originate from an untrusted source, those resources might contain JavaScript code which will be executed in the context of the build process.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-21316

Code Behaviors & Features

Detect and mitigate CVE-2021-21316 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.10.0

Fixed versions

  • 0.10.0

Solution

Upgrade to version 0.10.0 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-74: Improper Neutralization of Special Elements in Output Used by a Downstream Component ('Injection')

Source file

npm/less-openui5/CVE-2021-21316.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:21 +0000.