Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. larvitbase-api
  4. ›
  5. CVE-2019-5479

CVE-2019-5479: Unintended Require

September 3, 2019 (updated October 9, 2019)

An unintended require vulnerability in larvitbase-api may allow an attacker to load arbitrary non-production code (JavaScript file).

References

  • hackerone.com/reports/566056
  • nvd.nist.gov/vuln/detail/CVE-2019-5479

Code Behaviors & Features

Detect and mitigate CVE-2019-5479 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.5.5

Fixed versions

  • 0.5.5

Solution

Upgrade to version 0.5.5 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-829: Inclusion of Functionality from Untrusted Control Sphere

Source file

npm/larvitbase-api/CVE-2019-5479.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.