Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. keystone
  4. ›
  5. CVE-2022-39322

CVE-2022-39322: Incorrect Authorization

October 25, 2022 (updated October 28, 2022)

@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their multiselect fields to use the field-level access control - if configured - is vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than multiselect are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the multiselect field.

References

  • github.com/keystonejs/keystone/commit/65c6ee3deef23605fc72b80230908696a7a65e7c
  • github.com/keystonejs/keystone/security/advisories/GHSA-6mhr-52mv-6v6f
  • nvd.nist.gov/vuln/detail/CVE-2022-39322

Code Behaviors & Features

Detect and mitigate CVE-2022-39322 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.2.0 before 2.3.1

Fixed versions

  • 4.0.0

Solution

Upgrade to version 4.0.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

npm/keystone/CVE-2022-39322.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:21 +0000.