Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. keycloak-js
  4. ›
  5. CVE-2017-7474

CVE-2017-7474: High severity vulnerability that affects keycloak-connect and keycloak-js

November 15, 2017 (updated January 8, 2021)

It was found that the Keycloak Node.js adapter - did not handle invalid tokens correctly. An attacker could use this flaw to bypass authentication and gain access to restricted information, or to possibly conduct further attacks.

References

  • rhn.redhat.com/errata/RHSA-2017-1203.html
  • bugzilla.redhat.com/show_bug.cgi?id=1445271
  • github.com/advisories/GHSA-mw35-24gh-f82w
  • nvd.nist.gov/vuln/detail/CVE-2017-7474

Code Behaviors & Features

Detect and mitigate CVE-2017-7474 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.5 before 3.1.0

Fixed versions

  • 3.1.0

Solution

Upgrade to version 3.1.0 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

npm/keycloak-js/CVE-2017-7474.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.