Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. keycloak-connect
  4. ›
  5. CVE-2018-14657

CVE-2018-14657: Improper Authentication

November 13, 2018 (updated October 9, 2019)

When TOPT enabled, an improper implementation of the Brute Force detection algorithm will not enforce its protection measures.

References

  • access.redhat.com/errata/RHSA-2018:3592
  • access.redhat.com/errata/RHSA-2018:3593
  • access.redhat.com/errata/RHSA-2018:3595
  • bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14657
  • nvd.nist.gov/vuln/detail/CVE-2018-14657

Code Behaviors & Features

Detect and mitigate CVE-2018-14657 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 4.2.1, version 4.3.0

Fixed versions

  • 4.4.0

Solution

Upgrade to version 4.4.0 or above.

Impact 8.1 HIGH

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-307: Improper Restriction of Excessive Authentication Attempts

Source file

npm/keycloak-connect/CVE-2018-14657.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:25 +0000.