Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. jsrsasign
  4. ›
  5. CVE-2021-30246

CVE-2021-30246: Improper Verification of Cryptographic Signature

April 7, 2021 (updated April 14, 2021)

In the jsrsasign package for Node.js, some invalid RSA PKCS#1 v1.5 signatures are mistakenly recognized to be valid. NOTE: there is no known practical attack.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-30246

Code Behaviors & Features

Detect and mitigate CVE-2021-30246 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 10.1.13

Fixed versions

  • 10.2.0

Solution

Upgrade to version 10.2.0 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-347: Improper Verification of Cryptographic Signature

Source file

npm/jsrsasign/CVE-2021-30246.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.