Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. jspreadsheet-ce
  4. ›
  5. CVE-2022-48115

CVE-2022-48115: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

February 18, 2023

The dropdown menu in jspreadsheet before v4.6.0 was discovered to be vulnerable to cross-site scripting (XSS).

References

  • github.com/advisories/GHSA-q82h-q47j-f492
  • github.com/jspreadsheet/ce
  • github.com/jspreadsheet/ce/issues/1587
  • nvd.nist.gov/vuln/detail/CVE-2022-48115

Code Behaviors & Features

Detect and mitigate CVE-2022-48115 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.6.0

Fixed versions

  • 4.6.0

Solution

Upgrade to version 4.6.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/jspreadsheet-ce/CVE-2022-48115.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.