Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. jsoneditor
  4. ›
  5. CVE-2021-3822

CVE-2021-3822: Incorrect Comparison

September 27, 2021 (updated July 29, 2022)

jsoneditor is vulnerable to Inefficient Regular Expression Complexity

References

  • nvd.nist.gov/vuln/detail/CVE-2021-3822

Code Behaviors & Features

Detect and mitigate CVE-2021-3822 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 9.5.6

Fixed versions

  • 9.5.6

Solution

Upgrade to version 9.5.6 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-400: Uncontrolled Resource Consumption

Source file

npm/jsoneditor/CVE-2021-3822.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.