Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. jpv
  4. ›
  5. CVE-2019-19507

CVE-2019-19507: Improper Authentication

December 4, 2019 (updated August 19, 2021)

In jpv (aka Json Pattern Validator) before 2.1.1, compareCommon() can be bypassed because certain internal attributes can be overwritten via a conflicting name, as demonstrated by ‘constructor’: {’name’:‘Array’}. This affects validate(). Hence, a crafted payload can overwrite this builtin attribute to manipulate the type detection result.

References

  • github.com/advisories/GHSA-rh46-3fgc-mvrf
  • github.com/manvel-khnkoyan/jpv/issues/6
  • nvd.nist.gov/vuln/detail/CVE-2019-19507
  • www.npmjs.com/package/jpv

Code Behaviors & Features

Detect and mitigate CVE-2019-19507 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.1

Fixed versions

  • 2.1.1

Solution

Upgrade to version 2.1.1 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-287: Improper Authentication

Source file

npm/jpv/CVE-2019-19507.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.