Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. izimodal
  4. ›
  5. CVE-2021-32860

CVE-2021-32860: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

February 21, 2023 (updated February 22, 2023)

iziModal is a modal plugin with jQuery. Versions prior to 1.6.1 is vulnerable to cross-site scripting (XSS) when handling untrusted modal titles. An attacker who is able to influence the field title when creating a iziModal instance is able to supply arbitrary html or javascript code that will be rendered in the context of a user, potentially leading to XSS. Version 1.6.1 contains a patch for this issue

References

  • github.com/advisories/GHSA-h685-83w4-3ph3
  • github.com/marcelodolza/iziModal/commit/01728ac52bac5c1b4512087dafe0ad8b091fdc9e
  • github.com/marcelodolza/iziModal/issues/249
  • nvd.nist.gov/vuln/detail/CVE-2021-32860
  • securitylab.github.com/advisories/GHSL-2021-1044_iziModal/

Code Behaviors & Features

Detect and mitigate CVE-2021-32860 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.1

Fixed versions

  • 1.6.1

Solution

Upgrade to version 1.6.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/izimodal/CVE-2021-32860.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:39 +0000.