Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. i18next
  4. ›
  5. CVE-2017-16008

CVE-2017-16008: Cross-site Scripting

June 4, 2018 (updated October 9, 2019)

Because of how string interpolation is implemented, making replacements from the dictionary one at a time, untrusted user input can use the name of one of the dictionary keys to inject script into the browser.

References

  • github.com/i18next/i18next/pull/443
  • nvd.nist.gov/vuln/detail/CVE-2017-16008

Code Behaviors & Features

Detect and mitigate CVE-2017-16008 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.10.2

Fixed versions

  • 1.10.3

Solution

Upgrade to version 1.10.3 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/i18next/CVE-2017-16008.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:50 +0000.