Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. got-fetch
  4. ›
  5. CVE-2025-54313

CVE-2025-54313: eslint-config-prettier, eslint-plugin-prettier, synckit, @pkgr/core, napi-postinstall have embedded malicious code

July 19, 2025 (updated January 22, 2026)

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

References

  • checkmarx.com/zero-post/supply-chain-phishing-campaign-drops-more-malware-into-npm-got-fetch-5-1
  • github.com/advisories/GHSA-f29h-pxvx-f335
  • github.com/community-scripts/ProxmoxVE/discussions/6115
  • github.com/prettier/eslint-config-prettier
  • github.com/prettier/eslint-config-prettier/commit/9b0b0a47ec28a7a83cf65e8436a8776910379385
  • github.com/prettier/eslint-config-prettier/issues/339
  • github.com/prettier/eslint-plugin-prettier/commit/ec39dd4400f10c52d10cd991c10fa8de51ceb854
  • github.com/un-ts/napi-postinstall/commit/38b4e95cf554e2549b9e1e2c4ff6bff4da9a65f9
  • github.com/un-ts/pkgr/commit/e1420c99e44d8a2ae949381f9fbe1af5ba9cb1dd
  • github.com/un-ts/synckit/commit/8f2ee32d4f75736a1c8d7e1101190a71e48909e4
  • news.ycombinator.com/item?id=44608811
  • news.ycombinator.com/item?id=44609732
  • nvd.nist.gov/vuln/detail/CVE-2025-54313
  • secure.software/npm/packages/got-fetch
  • socket.dev/blog/npm-phishing-campaign-leads-to-prettier-tooling-packages-compromise
  • www.bleepingcomputer.com/news/security/popular-npm-linter-packages-hijacked-via-phishing-to-drop-malware
  • www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-54313
  • www.endorlabs.com/learn/cve-2025-54313-eslint-config-prettier-compromise----high-severity-but-windows-only
  • www.npmjs.com/package/eslint-config-prettier?activeTab=versions
  • www.stepsecurity.io/blog/supply-chain-security-alert-eslint-config-prettier-package-shows-signs-of-compromise

Code Behaviors & Features

Detect and mitigate CVE-2025-54313 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.1.11 before 6.0.0

Fixed versions

  • 6.0.0

Solution

Upgrade to version 6.0.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-506: Embedded Malicious Code

Source file

npm/got-fetch/CVE-2025-54313.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:27 +0000.