Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. gettext.js
  4. ›
  5. CVE-2024-43370

CVE-2024-43370: gettext.js has a Cross-site Scripting injection

August 15, 2024

Possible vulnerability to XSS injection if .po dictionary definition files is corrupted

References

  • github.com/advisories/GHSA-vwhg-jwr4-vxgg
  • github.com/guillaumepotier/gettext.js
  • github.com/guillaumepotier/gettext.js/security/advisories/GHSA-vwhg-jwr4-vxgg
  • nvd.nist.gov/vuln/detail/CVE-2024-43370

Code Behaviors & Features

Detect and mitigate CVE-2024-43370 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.0.3

Fixed versions

  • 2.0.3

Solution

Upgrade to version 2.0.3 or above.

Impact 7.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/gettext.js/CVE-2024-43370.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.