Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. gatsby-source-wordpress
  4. ›
  5. CVE-2021-32770

CVE-2021-32770: Insufficiently Protected Credentials

July 15, 2021 (updated October 25, 2022)

Gatsby is a framework for building websites. The gatsby-source-wordpress plugin leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-32770

Code Behaviors & Features

Detect and mitigate CVE-2021-32770 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.0.8, all versions starting from 5.0.0 before 5.9.2

Fixed versions

  • 4.0.8
  • 5.9.2

Solution

Upgrade to versions 4.0.8, 5.9.2 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

npm/gatsby-source-wordpress/CVE-2021-32770.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.