Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise
  4. ›
  5. GHSA-2qqc-p94c-hxwh

GHSA-2qqc-p94c-hxwh: Flowise: Weak Default Express Session Secret

April 16, 2026

Detection Method: Kolega.dev Deep Code Scan

AttributeValue
Locationpackages/server/src/enterprise/middleware/passport/index.ts:55
Practical ExploitabilityHigh
Developer Approverfaizan@kolega.ai

References

  • github.com/FlowiseAI/Flowise/security/advisories/GHSA-2qqc-p94c-hxwh
  • github.com/advisories/GHSA-2qqc-p94c-hxwh

Code Behaviors & Features

Detect and mitigate GHSA-2qqc-p94c-hxwh with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.0

Fixed versions

  • 3.1.0

Solution

Upgrade to version 3.1.0 or above.

Impact 5.6 MEDIUM

CVSS:3.0/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-798: Use of Hard-coded Credentials

Source file

npm/flowise/GHSA-2qqc-p94c-hxwh.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.