Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise
  4. ›
  5. CVE-2026-46443

CVE-2026-46443: FlowiseAI Vulnerable to Credential Data Leak

May 14, 2026 (updated June 9, 2026)

Severity: HIGH (CVSS ~7.5) Type: CWE-200 (Exposure of Sensitive Information) File: packages/server/src/services/credentials/index.ts:62-71

Description: When credentials are fetched with a credentialName filter parameter, the encryptedData field is NOT stripped from the response. The code properly omits encryptedData when NO filter is used (line 102) but fails to do so when a filter IS used (lines 62-63, 70-71). Credential Data Leak Evidence:

// Lines 62-63: WITH filter - encryptedData LEAKED
const credentials = await appServer.AppDataSource.getRepository(Credential).findBy(searchOptions)
dbResponse.push(...credentials)  // encryptedData NOT removed!

// Lines 100-102: WITHOUT filter - encryptedData properly omitted
for (const credential of credentials) {
dbResponse.push(omit(credential, ['encryptedData']))  // Correctly omitted
}

Impact: Authenticated users can extract encrypted credential data (API keys, passwords, tokens for services like OpenAI, AWS, etc.). Combined with access to the encryption key file (~/.flowise/encryption.key written with default permissions), this enables full credential theft.

Reproduction:

curl https://TARGET/api/v1/credentials?credentialName=openAIApi \
-H "Authorization: Bearer API_KEY"

References

  • github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2
  • github.com/FlowiseAI/Flowise/security/advisories/GHSA-7g73-99r4-m4mj
  • github.com/advisories/GHSA-7g73-99r4-m4mj
  • nvd.nist.gov/vuln/detail/CVE-2026-46443

Code Behaviors & Features

Detect and mitigate CVE-2026-46443 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.2

Fixed versions

  • 3.1.2

Solution

Upgrade to version 3.1.2 or above.

Impact 6.3 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Source file

npm/flowise/CVE-2026-46443.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:45 +0000.