Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise
  4. ›
  5. CVE-2026-46440

CVE-2026-46440: FlowiseAI Exposes Basic Auth Credentials via API

May 14, 2026 (updated June 9, 2026)

Detection Method: Kolega.dev Deep Code Scan

AttributeValue
SeverityMedium
CWECWE-522 (Insufficiently Protected Credentials)
Locationpackages/server/src/enterprise/controllers/account.controller.ts:128-135
Practical ExploitabilityMedium
Developer Approverfaizan@kolega.ai

References

  • github.com/FlowiseAI/Flowise/releases/tag/flowise%403.1.2
  • github.com/FlowiseAI/Flowise/security/advisories/GHSA-php6-83fg-gw3g
  • github.com/advisories/GHSA-php6-83fg-gw3g
  • nvd.nist.gov/vuln/detail/CVE-2026-46440

Code Behaviors & Features

Detect and mitigate CVE-2026-46440 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.2

Fixed versions

  • 3.1.2

Solution

Upgrade to version 3.1.2 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

npm/flowise/CVE-2026-46440.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:58 +0000.