Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise
  4. ›
  5. CVE-2026-41266

CVE-2026-41266: Flowise: Sensitive Data Leak in public-chatbotConfig

April 16, 2026 (updated April 24, 2026)

/api/v1/public-chatbotConfig/:id ep exposes sensitive data including API keys, HTTP authorization headers and internal configuration without any authentication. An attacker with knowledge just of a chatflow UUID can retrieve credentials stored in password type fields and HTTP headers, leading to credential theft and more.

References

  • github.com/FlowiseAI/Flowise/security/advisories/GHSA-4jpm-cgx2-8h37
  • github.com/advisories/GHSA-4jpm-cgx2-8h37
  • nvd.nist.gov/vuln/detail/CVE-2026-41266

Code Behaviors & Features

Detect and mitigate CVE-2026-41266 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.0

Fixed versions

  • 3.1.0

Solution

Upgrade to version 3.1.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
  • CWE-522: Insufficiently Protected Credentials
  • CWE-862: Missing Authorization

Source file

npm/flowise/CVE-2026-41266.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:26 +0000.