Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise
  4. ›
  5. CVE-2024-9148

CVE-2024-9148: Flowise and Flowise Chat Embed vulnerable to Stored Cross-site Scripting

September 25, 2024 (updated September 30, 2024)

Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.

References

  • github.com/FlowiseAI/Flowise/commit/8375ebb4ec1ebb2b1295561cc0f63486a29f3fde
  • github.com/FlowiseAI/Flowise/releases/tag/flowise%402.1.1
  • github.com/FlowiseAI/FlowiseChatEmbed
  • github.com/FlowiseAI/FlowiseChatEmbed/commit/6a9645df41371cb69f251038d501ec87b1304c84
  • github.com/FlowiseAI/FlowiseChatEmbed/releases/tag/flowise-embed%402.0.0
  • github.com/advisories/GHSA-m5p9-xvxj-64c8
  • nvd.nist.gov/vuln/detail/CVE-2024-9148
  • www.tenable.com/security/research/tra-2024-40

Code Behaviors & Features

Detect and mitigate CVE-2024-9148 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.1

Fixed versions

  • 2.1.1

Solution

Upgrade to version 2.1.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/flowise/CVE-2024-9148.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:08 +0000.