Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise
  4. ›
  5. CVE-2024-31621

CVE-2024-31621: Flowise vulnerable to code injection via api/v1

April 29, 2024 (updated August 2, 2024)

An issue in FlowiseAI Inc Flowise prior to v1.8.1 allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.

References

  • flowiseai.com/
  • github.com/FlowiseAI/Flowise
  • github.com/FlowiseAI/Flowise/blob/flowise%401.6.5/packages/server/src/index.ts
  • github.com/FlowiseAI/Flowise/commit/e32b64344544312bf38b3e1fefe7b26c1776a426
  • github.com/advisories/GHSA-6wp6-22x5-rr3w
  • nvd.nist.gov/vuln/detail/CVE-2024-31621
  • www.exploit-db.com/exploits/52001

Code Behaviors & Features

Detect and mitigate CVE-2024-31621 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.8.1

Fixed versions

  • 1.8.1

Solution

Upgrade to version 1.8.1 or above.

Impact 7.6 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L

Learn more about CVSS

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

Source file

npm/flowise/CVE-2024-31621.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.