Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. flowise-components
  4. ›
  5. GHSA-cvrr-qhgw-2mm6

GHSA-cvrr-qhgw-2mm6: Flowise: Parameter Override Bypass Remote Command Execution

April 16, 2026

Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance.

References

  • github.com/FlowiseAI/Flowise
  • github.com/FlowiseAI/Flowise/security/advisories/GHSA-cvrr-qhgw-2mm6
  • github.com/advisories/GHSA-cvrr-qhgw-2mm6

Code Behaviors & Features

Detect and mitigate GHSA-cvrr-qhgw-2mm6 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.1.0

Fixed versions

  • 3.1.0

Solution

Upgrade to version 3.1.0 or above.

Impact 7.7 HIGH

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/flowise-components/GHSA-cvrr-qhgw-2mm6.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:54 +0000.