Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. fast-uri
  4. ›
  5. CVE-2026-75931

CVE-2026-75931: fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references

September 2, 2026

fast-uri canonicalizes a host to its ASCII form only when the input carries an explicit scheme. When resolve() resolves a scheme-relative reference (//host/) against a scheme-bearing base, it still emits the host verbatim even though the effective scheme is known, so re-parsing the resolved URI yields a different host than the one resolve() returned. An application that resolves an untrusted reference with fast-uri and then checks or routes on the resulting host can make a policy decision on one host and reach another. This is an incomplete-fix variant of CVE-2026-13676, whose IDN canonicalization was applied only to the scheme-bearing form.

References

  • cna.openjsf.org/security-advisories.html
  • github.com/advisories/GHSA-5jgf-p345-68v8
  • github.com/fastify/fast-uri/commit/0256bc8d1f28b5d0ac657faf67e2411a189dfcb5
  • github.com/fastify/fast-uri/commit/444ecdad447db2cc23c4d422acc6f0daa6fa8eef
  • github.com/fastify/fast-uri/commit/4e4ebd8b245f6ca16e448203559eea3e545453a3
  • github.com/fastify/fast-uri/releases/tag/v2.4.5
  • github.com/fastify/fast-uri/releases/tag/v3.1.6
  • github.com/fastify/fast-uri/releases/tag/v4.1.3
  • github.com/fastify/fast-uri/security/advisories/GHSA-5jgf-p345-68v8
  • nvd.nist.gov/vuln/detail/CVE-2026-75931

Code Behaviors & Features

Detect and mitigate CVE-2026-75931 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.4.2 before 2.4.5, all versions starting from 3.1.3 before 3.1.6, all versions starting from 4.0.1 before 4.1.3

Fixed versions

  • 2.4.5
  • 3.1.6
  • 4.1.3

Solution

Upgrade to versions 2.4.5, 3.1.6, 4.1.3 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-436: Interpretation Conflict

Source file

npm/fast-uri/CVE-2026-75931.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:49 +0000.