Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. fast-uri
  4. ›
  5. CVE-2026-16221

CVE-2026-16221: fast-uri vulnerable to host confusion via literal backslash authority delimiter

July 21, 2026

fast-uri v4.1.0 and earlier do not treat a literal backslash (U+005C) as an authority delimiter. Node’s native WHATWG URL (used by fetch(), undici, and Node’s http/https clients) normalizes \ to / for special schemes (http, https, ws, wss, ftp, file), so the two parsers extract different hosts from the same input string.

For example, http://evil.com\@allowed.com is treated by fast-uri as host allowed.com with userinfo evil.com\, while Node’s WHATWG URL parser and fetch() see host evil.com with path /@allowed.com.

Applications that use fast-uri to enforce host-based policy (allowlists, denylists, loopback/SSRF filtering, redirect validation, outbound proxy routing) before passing the same URL into Node’s URL or fetch() consumers see a policy/use desync and can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts.

References

  • cna.openjsf.org/security-advisories.html
  • github.com/advisories/GHSA-v2hh-gcrm-f6hx
  • github.com/fastify/fast-uri/commit/0542a216860fd70c062a4730e620576f62ded057
  • github.com/fastify/fast-uri/commit/2d50fbabc80e4d0884fe0f6a98fe118ce6faa353
  • github.com/fastify/fast-uri/commit/9438266d6a7ded688c8bc7c4ba506da17f44a17b
  • github.com/fastify/fast-uri/releases/tag/v2.4.3
  • github.com/fastify/fast-uri/releases/tag/v3.1.4
  • github.com/fastify/fast-uri/releases/tag/v4.1.1
  • github.com/fastify/fast-uri/security/advisories/GHSA-v2hh-gcrm-f6hx
  • nvd.nist.gov/vuln/detail/CVE-2026-16221

Code Behaviors & Features

Detect and mitigate CVE-2026-16221 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 2.3.1 before 2.4.3, all versions starting from 3.0.0 before 3.1.4, all versions starting from 4.0.0 before 4.1.1

Fixed versions

  • 2.4.3
  • 3.1.4
  • 4.1.1

Solution

Upgrade to versions 2.4.3, 3.1.4, 4.1.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-436: Interpretation Conflict

Source file

npm/fast-uri/CVE-2026-16221.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:50 +0000.