Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. fast-jwt
  4. ›
  5. CVE-2025-30144

CVE-2025-30144: Fast-JWT Improperly Validates iss Claims

March 19, 2025 (updated March 20, 2025)

The fast-jwt library does not properly validate the iss claim based on the RFC https://datatracker.ietf.org/doc/html/rfc7519#page-9.

References

  • datatracker.ietf.org/doc/html/rfc7519
  • github.com/advisories/GHSA-gm45-q3v2-6cf8
  • github.com/nearform/fast-jwt
  • github.com/nearform/fast-jwt/commit/cc26b1d473f900446ad846f8f0b10eb1c0adcbdd
  • github.com/nearform/fast-jwt/security/advisories/GHSA-gm45-q3v2-6cf8
  • nvd.nist.gov/vuln/detail/CVE-2025-30144

Code Behaviors & Features

Detect and mitigate CVE-2025-30144 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.0.6

Fixed versions

  • 5.0.6

Solution

Upgrade to version 5.0.6 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-290: Authentication Bypass by Spoofing

Source file

npm/fast-jwt/CVE-2025-30144.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.