Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. fancy-server
  4. ›
  5. CVE-2014-10066

CVE-2014-10066: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

August 31, 2020 (updated January 7, 2021)

Versions less than 0.1.4 of the static file server module fancy-server are vulnerable to directory traversal. An attacker can provide input such as ../ to read files outside of the served directory.

References

  • en.wikipedia.org/wiki/Directory_traversal_attack
  • github.com/advisories/GHSA-m273-wwfv-h6jp
  • nodesecurity.io/advisories/9
  • nvd.nist.gov/vuln/detail/CVE-2014-10066
  • www.npmjs.com/advisories/9

Code Behaviors & Features

Detect and mitigate CVE-2014-10066 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.1.4

Fixed versions

  • 0.1.4

Solution

Upgrade to version 0.1.4 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

npm/fancy-server/CVE-2014-10066.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:58 +0000.