Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. express-jwt
  4. ›
  5. CVE-2020-15084

CVE-2020-15084: Improper Authorization

June 30, 2020 (updated July 8, 2020)

In express-jwt (NPM package) up and including, the algorithms entry to be specified in the configuration is not being enforced. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-15084

Code Behaviors & Features

Detect and mitigate CVE-2020-15084 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 5.3.3

Fixed versions

  • 6.0.0

Solution

Upgrade to version 6.0.0 or above.

Impact 9.1 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-285: Improper Authorization

Source file

npm/express-jwt/CVE-2020-15084.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.