Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. express-cart
  4. ›
  5. CVE-2021-32573

CVE-2021-32573: Cross-site Scripting

May 11, 2021 (updated November 7, 2023)

(This issue is currently in DISPUTED state). The express-cart package for Node.js allows Reflected XSS (for an admin) via a user input field for product options. The vendor states that this “would rely on an admin hacking his/her own website.”

References

  • nvd.nist.gov/vuln/detail/CVE-2021-32573

Code Behaviors & Features

Detect and mitigate CVE-2021-32573 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 1.1.10

Fixed versions

  • 1.1.11

Solution

Upgrade to version 1.1.11 or above.

Impact 4.8 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/express-cart/CVE-2021-32573.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:09 +0000.