Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. erxes
  4. ›
  5. CVE-2024-57190

CVE-2024-57190: Erxes Incorrect Access Control vulnerability

June 10, 2025 (updated November 10, 2025)

Erxes <1.6.1 is vulnerable to Incorrect Access Control. An attacker can bypass authentication by providing a “User” HTTP header that contains any user, allowing them to talk to any GraphQL endpoint.

References

  • github.com/advisories/GHSA-7rhv-xm4q-wh42
  • github.com/erxes/erxes
  • github.com/erxes/erxes/commit/4ed2ca797241d2ba0c9083feeadd9755c1310ce8
  • nvd.nist.gov/vuln/detail/CVE-2024-57190
  • www.sonarsource.com/blog/micro-services-major-headaches-detecting-vulnerabilities-in-erxes-microservices

Code Behaviors & Features

Detect and mitigate CVE-2024-57190 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.1

Fixed versions

  • 1.6.1

Solution

Upgrade to version 1.6.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-284: Improper Access Control
  • CWE-287: Improper Authentication

Source file

npm/erxes/CVE-2024-57190.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:35 +0000.