Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ep_etherpad-lite
  4. ›
  5. CVE-2018-6835

CVE-2018-6835: Improper Input Validation

May 13, 2022 (updated July 24, 2023)

node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.

References

  • github.com/advisories/GHSA-mvmv-rq2j-97p2
  • github.com/ether/etherpad-lite/commit/626e58cc5af1db3691b41fca7b06c28ea43141b1
  • github.com/ether/etherpad-lite/releases/tag/1.6.3
  • nvd.nist.gov/vuln/detail/CVE-2018-6835

Code Behaviors & Features

Detect and mitigate CVE-2018-6835 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.3

Fixed versions

  • 1.6.3

Solution

Upgrade to version 1.6.3 or above.

Impact 9.8 CRITICAL

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/ep_etherpad-lite/CVE-2018-6835.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:19 +0000.