Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. electron
  4. ›
  5. CVE-2022-36077

CVE-2022-36077: Insufficiently Protected Credentials

November 8, 2022 (updated November 9, 2022)

The Electron framework enables writing cross-platform desktop applications using JavaScript, HTML and CSS. In versions prior to 21.0.0-beta.1, 20.0.1, 19.0.11, and 18.3.7, Electron is vulnerable to Exposure of Sensitive Information. When following a redirect, Electron delays a check for redirecting to file:// URLs from other schemes. The contents of the file is not available to the renderer following the redirect, but if the redirect target is a SMB URL such as file://some.website.com/, then in some cases, Windows will connect to that server and attempt NTLM authentication, which can include sending hashed credentials.This issue has been patched in versions: 21.0.0-beta.1, 20.0.1, 19.0.11, and 18.3.7. Users are recommended to upgrade to the latest stable version of Electron. If upgrading isn’t possible, this issue can be addressed without upgrading by preventing redirects to file:// URLs in the WebContents.on('will-redirect') event, for all WebContents as a workaround.

References

  • github.com/electron/electron/security/advisories/GHSA-p2jh-44qj-pf2v
  • nvd.nist.gov/vuln/detail/CVE-2022-36077

Code Behaviors & Features

Detect and mitigate CVE-2022-36077 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 18.3.7, all versions starting from 19.0.0 before 19.0.11, all versions starting from 20.0.0 before 20.0.1, version 21.0.0

Fixed versions

  • 18.3.7
  • 19.0.11
  • 20.0.1
  • 21.0.1

Solution

Upgrade to versions 18.3.7, 19.0.11, 20.0.1, 21.0.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-522: Insufficiently Protected Credentials

Source file

npm/electron/CVE-2022-36077.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.