Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ejs
  4. ›
  5. CVE-2017-1000188

CVE-2017-1000188: Cross-site Scripting

November 17, 2017 (updated November 30, 2017)

The ejs module is vulnerable to a Cross-site-scripting in ejs.renderFile().

References

  • www.securityfocus.com/bid/101889
  • nvd.nist.gov/vuln/detail/CVE-2017-1000188

Code Behaviors & Features

Detect and mitigate CVE-2017-1000188 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.5.5

Fixed versions

  • 2.5.5

Solution

Upgrade to version 2.5.5 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ejs/CVE-2017-1000188.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:10 +0000.