Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. edge.js
  4. ›
  5. CVE-2021-23443

CVE-2021-23443: Cross-site Scripting

September 21, 2021 (updated May 3, 2022)

A type confusion vulnerability can be used to bypass input sanitization when the input to be rendered is an array (instead of a string or a SafeValue), even if {{ }} are used.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-23443

Code Behaviors & Features

Detect and mitigate CVE-2021-23443 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.3.2

Fixed versions

  • 5.3.2

Solution

Upgrade to version 5.3.2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-843: Access of Resource Using Incompatible Type ('Type Confusion')

Source file

npm/edge.js/CVE-2021-23443.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:04 +0000.