Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. droppy
  4. ›
  5. CVE-2016-10529

CVE-2016-10529: Cross-Site Request Forgery (CSRF)

February 18, 2019 (updated January 7, 2021)

Droppy versions <3.5.0 does not perform any verification for cross-domain websocket requests. An attacker is able to make a specially crafted page that can send requests as the context of the currently logged in user. For example this means the malicious user could add a new admin account under his control and delete others.

References

  • github.com/advisories/GHSA-rhvc-x32h-5526
  • nodesecurity.io/advisories/91
  • nvd.nist.gov/vuln/detail/CVE-2016-10529
  • www.npmjs.com/advisories/91

Code Behaviors & Features

Detect and mitigate CVE-2016-10529 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.5.0

Fixed versions

  • 3.5.0

Solution

Upgrade to version 3.5.0 or above.

Impact 8.8 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-352: Cross-Site Request Forgery (CSRF)

Source file

npm/droppy/CVE-2016-10529.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:19 +0000.