Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. docsify
  4. ›
  5. CVE-2020-7680

CVE-2020-7680: Cross-site Scripting

July 20, 2020 (updated February 24, 2021)

docsify is susceptible to Cross-site Scripting (XSS). Docsify.js uses fragment identifiers (parameters after # sign) to load resources from server-side .md files. Due to lack of validation here, it is possible to provide external URLs and render arbitrary JavaScript/HTML inside docsify page.

References

  • packetstormsecurity.com/files/158515/Docsify.js-4.11.4-Cross-Site-Scripting.html
  • nvd.nist.gov/vuln/detail/CVE-2020-7680

Code Behaviors & Features

Detect and mitigate CVE-2020-7680 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.11.4

Fixed versions

  • 4.11.4

Solution

Upgrade to version 4.11.4 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/docsify/CVE-2020-7680.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:06 +0000.