Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. diagram-js
  4. ›
  5. GMS-2020-226

GMS-2020-226: Cross-Site Scripting in diagram-js

September 11, 2020 (updated September 28, 2021)

Versions of diagram-js (f ) (f ) are vulnerable to Cross-Site Scripting. The package fails to escape output of user-controlled input in search-pad, allowing attackers to execute arbitrary JavaScript. If you are using diagram-js, upgrade to If you are using diagram-js, upgrade to

References

  • github.com/advisories/GHSA-8fw4-xh83-3j6q
  • github.com/bpmn-io/diagram-js
  • www.npmjs.com/advisories/982

Code Behaviors & Features

Detect and mitigate GMS-2020-226 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.6.2, all versions starting from 3.0.0 before 3.3.1

Fixed versions

  • 2.6.2
  • 3.3.1

Solution

Upgrade to versions 2.6.2, 3.3.1 or above.

Source file

npm/diagram-js/GMS-2020-226.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:03 +0000.