Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. devalue
  4. ›
  5. CVE-2026-22774

CVE-2026-22774: Devalue is vulnerable to denial of service due to memory exhaustion in devalue.parse

January 15, 2026

Certain inputs can cause devalue.parse to consume excessive CPU time and/or memory, potentially leading to denial of service in systems that parse input from untrusted sources. This affects applications using devalue.parse on externally-supplied data. The root cause is the typed array hydration expecting an ArrayBuffer as input, but not checking the assumption before creating the typed array.

References

  • github.com/advisories/GHSA-vw5p-8cq8-m7mv
  • github.com/sveltejs/devalue
  • github.com/sveltejs/devalue/commit/11755849fa0634ae294a15ec0aef2f43efcad7c4
  • github.com/sveltejs/devalue/security/advisories/GHSA-vw5p-8cq8-m7mv
  • nvd.nist.gov/vuln/detail/CVE-2026-22774

Code Behaviors & Features

Detect and mitigate CVE-2026-22774 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.3.0 before 5.6.2

Fixed versions

  • 5.6.2

Solution

Upgrade to version 5.6.2 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-405: Asymmetric Resource Consumption (Amplification)

Source file

npm/devalue/CVE-2026-22774.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.