Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. decode-uri-component
  4. ›
  5. CVE-2022-38900

CVE-2022-38900: decode-uri-component vulnerable to Denial of Service (DoS)

November 28, 2022 (updated November 7, 2023)

decode-uri-component 0.2.0 is vulnerable to Improper Input Validation resulting in DoS.

References

  • github.com/SamVerschueren/decode-uri-component/issues/5
  • github.com/advisories/GHSA-w573-4hg7-7wgq
  • github.com/sindresorhus/query-string/issues/345
  • nvd.nist.gov/vuln/detail/CVE-2022-38900

Code Behaviors & Features

Detect and mitigate CVE-2022-38900 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 0.2.0

Fixed versions

  • 0.2.1

Solution

Upgrade to version 0.2.1 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/decode-uri-component/CVE-2022-38900.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:34 +0000.