Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. decode-uri-component
  4. ›
  5. CVE-2022-38778

CVE-2022-38778: Improper Input Validation

February 8, 2023 (updated February 16, 2023)

A flaw (CVE-2022-38900) was discovered in one of Kibana’s third party dependencies, that could allow an authenticated user to perform a request that crashes the Kibana server process.

References

  • discuss.elastic.co/t/elastic-7-17-9-8-5-0-and-8-6-1-security-update/324661
  • nvd.nist.gov/vuln/detail/CVE-2022-38778
  • www.elastic.co/community/security

Code Behaviors & Features

Detect and mitigate CVE-2022-38778 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.2.1

Fixed versions

  • 0.2.1

Solution

Upgrade to version 0.2.1 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/decode-uri-component/CVE-2022-38778.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:31 +0000.