Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ctrip-apollo
  4. ›
  5. CVE-2020-15170

CVE-2020-15170: Improper Input Validation

September 10, 2020 (updated November 18, 2021)

apollo-adminservice does not implement access controls. If users expose apollo-adminservice to internet(which is not recommended), there are potential security issues since apollo-adminservice is designed to work in intranet and it does not have access control built-in. Malicious hackers may access apollo-adminservice apis directly to access/edit the application’s configurations. To fix the potential issue without upgrading, simply follow the advice that do not expose apollo-adminservice to internet.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-15170

Code Behaviors & Features

Detect and mitigate CVE-2020-15170 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.7.1

Fixed versions

  • 2.0.0

Solution

Upgrade to version 2.0.0 or above.

Impact 7 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L

Learn more about CVSS

Source file

npm/ctrip-apollo/CVE-2020-15170.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:53 +0000.