Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. controlled-merge
  4. ›
  5. CVE-2020-28268

CVE-2020-28268: Improper Input Validation

November 15, 2020 (updated July 21, 2021)

A prototype pollution vulnerability in controlled-merge may allow an attacker to cause a denial of service, or possibly lead to remote code execution.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-28268

Code Behaviors & Features

Detect and mitigate CVE-2020-28268 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.0 up to 1.2.0

Fixed versions

  • 1.3.0

Solution

Upgrade to version 1.3.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/controlled-merge/CVE-2020-28268.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:02 +0000.