Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. code-server
  4. ›
  5. CVE-2021-42648

CVE-2021-42648: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

May 12, 2022 (updated May 24, 2022)

Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.

References

  • github.com/advisories/GHSA-2gp3-6c9p-jp7w
  • github.com/cdr/code-server/issues/4355
  • github.com/coder/code-server/pull/4430
  • nvd.nist.gov/vuln/detail/CVE-2021-42648

Code Behaviors & Features

Detect and mitigate CVE-2021-42648 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.12.0

Fixed versions

  • 3.12.0

Solution

Upgrade to version 3.12.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/code-server/CVE-2021-42648.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:17 +0000.