Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ckeditor5
  4. ›
  5. CVE-2024-45613

CVE-2024-45613: Cross-site scripting (XSS) in the clipboard package

September 25, 2024 (updated October 15, 2024)

During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration.

This vulnerability affects only installations where the editor configuration meets the following criteria:

References

  • github.com/advisories/GHSA-rgg8-g5x8-wr9v
  • github.com/ckeditor/ckeditor5
  • github.com/ckeditor/ckeditor5/releases/tag/v43.1.1
  • github.com/ckeditor/ckeditor5/security/advisories/GHSA-rgg8-g5x8-wr9v
  • nvd.nist.gov/vuln/detail/CVE-2024-45613

Code Behaviors & Features

Detect and mitigate CVE-2024-45613 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 40.0.0 before 43.1.1

Fixed versions

  • 43.1.1

Solution

Upgrade to version 43.1.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/ckeditor5/CVE-2024-45613.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:08 +0000.